logo
Published on

Railsのバージョンを変更する

Authors

Rubyプログラミング言語において、Railsのバージョンを変更する方法について紹介します。

rails newする時,バージョン指定をする必要があることがある. 例えば,rails tutorial(Rails チュートリアル) では,rails 4.2.2 new sample_appのような書き方が必要. この時,rails 4.2.2 がインストールされていないとエラーがでる.

railsをバージョンを指定してインストールするためには,以下.

gem install rails -v 4.2.2

いくつのバージョンがインストールされているか確認する

gem search ^rails$ -l

すると,こうなる

PS Y:\files\pg\railsenv\sample_app> rails -v
Expected string default value for '--rc'; got false (boolean)
Rails 4.2.2
PS Y:\files\pg\railsenv\sample_app> cd ..
PS Y:\files\pg\railsenv> rails -v
Rails 5.1.1

各ツール価格:1万円~

サポート:6千円/1時間*

見積もり:無料


*一律・1時間未満切上

👉 詳細はこちらから。📧 お問い合わせ

ご覧いただき、ありがとうございます。本サイトの運営コストは広告をご覧いただくことで賄われています。様々な有名サービスが本サイト経由限定・期間限定で無料・割引・キャッシュバックになる、お得なプロモーションをご利用いただくことで、本サイトの運営をご支援いただけます。